Please help Urgently

Discussion in 'Technical' started by Ross M, Feb 28, 2016.

  1. Ross M

    Ross M New Member

    Trophy Points:
    3
    My Hoverboard has been fully charged ( 6 hours) and whenever I try to put it on it blinks one green light and then comes off the green light is the dot and also the battery please help
    JDBash likes this.
  2. JDBash

    JDBash Administrator Staff Member

    Trophy Points:
    3
    Hi Ross,

    Not entirely sure what's going on there.. so when you turn it on, the green battery indicator blinks on and then off straight away?

    An easy thing to try would be re-calibrating the board as follows:
    Just power off the board.
    Now hold the power button for 3 to 5 seconds, until the blue LEDs flash.
    Finally, turn the board off.

    Now turn it back on and see if it works normally.
    If the battery light is flashing on and then off immediately, I would think that there's a problem with the battery not being charged, which could be caused by a whole host of reasons.

    Has the problem started after taking a tumble on the board or was it just acting like that one day after charging it overnight?
  3. JDBash

    JDBash Administrator Staff Member

    Trophy Points:
    3
    I think a user here, Wulf, had the same problem: turned out to be a broken connection inside the battery pack. You can see the original post at the following link:
    http://hoverboardforums.net/threads/who-can-help.13/

    Now, and this is at your very own risk, and I don't recommend doing this unless you absolutely know what you're doing, but you can grab a replacement battery pack here, and then just swap it out. It should fix any problem, without having to solder the connection back yourself like Wulf did.

    Hope this helps..
  4. Ross M

    Ross M New Member

    Trophy Points:
    3
    Thanks a lot for taking the time to assess my situation but unfortunately when I press the off button for the 3-5 seconds no light appears . When The light flashes and comes off it turns out I have to wait like 3 minutes till I can press it and it will flash again . Thanks again!

Share This Page